close× Call Us +49 (1805) 01 29 59

Thread Author: Panter
Thread ID: 2270
Thread Info
Es gibt 7 Beiträge zu diesem Thema, und es wurde 4296 mal angesehen.
Wer ist hier? 1 Gäste
 Thema drucken
[Gelöst] Metatag
Panter
Hallo erst mal

Also mir ist heute mal was aufgefallen da ich noch arbeiten an einer web Seite mache.

Habe ich mal heute die Metatag ausgefüllt usw.

Die werden auch auf der Website angezeigt (rechtsklick Quelltext)

Aber wenn ich jetzt verschiedene Metatag Prüf Seiten nehme und lasse die Web Seite dann prüfen kommt nix

Ich habe auch mal andere Web Seiten genommen die auf PHP Fusion 7 aufgebaut sind und dort ist das gleiche.

Ich kann selbst die Seite hier nehmen und lasse sie Testen und nix kommt der sagt immer das der nix gefunden hat.

Ich habe mal einen Screen gemacht von der such anfange von der Seite hier und das ihr es besser versteht was ich meine.
Bearbeitet von Panter am 13.10.2010 00000010 12:57
 
SC-Ad-Bot
 
emblinux
Wo hast du es getestet und was hast du dort eingegeben ?

Als URL musst du natürlich die news.php oder eine andere Seite eintragen. Wenn du die index.php nimmst, ist das logisch, da sind diese Infos noch nicht vorhanden, weil diese nur zur Weiterleitung dient.
Das Lernen ist wie ein Meer ohne Ufer. Konfuzius

Alles wird Gut!

KEIN Support per Mail, ICQ oder PN !
www.heiseclan.de/fusion/sig.gif

www.heiseclan.de/geosig.gif
 
Panter
geprüft habe ich es hier http://www.6webmaster.com/homepagetoo.../index.php Google gefunden

und als Link habe ich nur http://domianname.de oder net usw.

Das funzt so weit auch bei allen anderen Web Seiten die ich getestet habe nur bei PHP Fusion nicht so wie du es geschrieben hast also mit der news.php habe ich nicht.

Edit: auch wenn ich z.b. die news.php nehme bekomme ich keine Metatag infos auch von der Seite hier....
Bearbeitet von Panter am 09.01.2010 00000001 07:36
 
emblinux
ich habe die Lösung gefunden.

in der Datei themes/templates/header.php werden die ganzen Meta-Tags ausgegeben. Dort steht am Ende immer /> , das darf anscheinend nicht sein.

Beispiel:
vorher:


echo "<meta name='description' content='".$settings['description']."' />\n";                                                         
echo "<meta name='keywords' content='".$settings['keywords']."' />\n";


muss aber so aussehen:


echo "<meta name='description' content='".$settings['description']."'>\n";                                                         
echo "<meta name='keywords' content='".$settings['keywords']."'>\n";


Ob das ganze nun ein Fehler von Fusion ist oder von der Meta-test-Seite weiß ich jetzt nicht ganz genau, dazu müsste ich mir erst die HTML-Spec anschauen.
Das Lernen ist wie ein Meer ohne Ufer. Konfuzius

Alles wird Gut!

KEIN Support per Mail, ICQ oder PN !
www.heiseclan.de/fusion/sig.gif

www.heiseclan.de/geosig.gif
 
Panter
emblinux erst mal danke aber wenn ich das mache was du geschrieben hast tut sich auch nix.

Wenn ich es so mache abspeicher udn dann wieder ein scan mache dann bekomme ich immer noch keine infos.......

Irgend wie sehr kommisch alles.....
 
emblinux
Also ich habe das auf meiner Seite getestet und da funktioniert es. Hast du auch das leerzeichen vor dem / entfernt, das ist auch noch sehr wichtig.

Und nach meiner kurzen Recherche schein das ein Problem von der Meta-test-Seite zu sein Denn laut XHTML sind diese Tags so wie sie in Fusion Standard sind richtig. Nur wenn man HTML 4 benutzt, müssen die / am Ende weg. Siehe dazu hier: http://de.wikipedia.org/wiki/Meta-Tag


EDIT: Hier mal eine Seite, die eine vernünftige analyse macht. http://www.meta-tags.de/website_analyse
Die unterstützt auch XHtml und nicht mehr das veraltete HTML 4.
Das Lernen ist wie ein Meer ohne Ufer. Konfuzius

Alles wird Gut!

KEIN Support per Mail, ICQ oder PN !
www.heiseclan.de/fusion/sig.gif

www.heiseclan.de/geosig.gif
 
Panter
ahh oki emblinux danke dir erst mal für deine schnelle hilfe

hatte bei mir noch ein fehler gehabt hatte die datei auf einen falschen Server gezogen rofl

danke dir erst mal dafür wie immer bekommt man hier schnellen Support einfach klasse die Seite.
 
Springe ins Forum:

 Ähnliche Themen 

TEST
Thema Forum Antworten Letzter Beitrag
[Gelöst] Foto Galerie Allgemeine Support Fragen 13 20.12.2014 00000012 16:58
[gelöst] Subdomain nicht als ext. Link anzeigen Allgemeine Support Fragen 9 01.01.2013 00000001 19:36
[gelöst] Kontaktdaten nicht einsehbar Allgemeine Support Fragen 12 04.12.2012 00000012 15:51
[Gelöst] ID Nummer anzeigen im Profil Allgemeine Support Fragen 46 20.08.2012 00000008 05:32
[gelöst] Design erstellen Grafik und Design 21 19.08.2012 00000008 05:32