close× Call Us +49 (1805) 01 29 59

Gr@n@dE
Thread Author: ingo21
Thread ID: 3585
Thread Info
Es gibt 7 Beiträge zu diesem Thema, und es wurde 3075 mal angesehen.
Wer ist hier? 1 Gäste
 Thema drucken
mysql_fetch_assoc()
ingo21
Hallo ich habe ein Problem mit meiner Maincore.php und zwar zeigt diese folgenden Fehler an.

Woran kann dies liegen. Ich wäre euch dankbar wenn einer einen Vorschlag hat.

Danke im vorraus
[geshi=mysql]232 function dbarray($query) {
233 $result = @mysql_fetch_assoc($query);
234 if (!$result) {
235 echo mysql_error();
236 return false;
237 } else {
238 return $result;
239 } [/geshi]

Error: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource Zeile: 233
Datei: htdocs/Marcel/maincore.php
 
SC-Ad-Bot
 
emblinux
Das Problem liegt sicher nicht in der maincore.php, sondern eher in der Verwendung der Funktion dbarray, der du anscheinend etwas falsches übergibst.

Denn wenn es daran liegen würde, würde deine komplette Seite nicht funktionieren. Doch davon gehe ich mal nicht aus.
Das Lernen ist wie ein Meer ohne Ufer. Konfuzius

Alles wird Gut!

KEIN Support per Mail, ICQ oder PN !
www.heiseclan.de/fusion/sig.gif

www.heiseclan.de/geosig.gif
 
ingo21
Die Seite Funktioniert nur wenn ich mich auf der Seite einloggen dann steht folgendes:

WARNING: An error occurred while parsing the page. Please see PHP-Fusion's error log for more details.

Aber nur auf der news.php

Und das gibt mir der errorlog aus:

Error: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource Zeile: 233
Datei: htdocs/Marcel/maincore.php

Daher komme ich auf die maincore.php
 
emblinux
Wie gesagt, es liegt ganz bestimmt nicht an der maincore.php

Wie lautet denn die URL zu deiner Seite.?
Das Lernen ist wie ein Meer ohne Ufer. Konfuzius

Alles wird Gut!

KEIN Support per Mail, ICQ oder PN !
www.heiseclan.de/fusion/sig.gif

www.heiseclan.de/geosig.gif
 
ingo21
Die URL lautet: http://marcel-fansite.de/news.php
Bearbeitet von ingo21 am 01.05.2011 00000005 17:31
 
emblinux
Dann schau mal, was die als Mitglied angezeigt wird, was du als Gast nicht siehst. Diese Panels musst du dir dann etwas genauer ansehen. Am besten diese deaktivieren und nach und nach aktivieren und schauen, wann der Fehler auftritt. Wenn du dann das entsprechende Panel gefunden hast, musst du dir dieses genauer ansehen, was dort falsch laufen könnte.

Vielleicht hast du auch nur etwas falsch eingebaut. Fällt dir noch ein, seit wann der Fehler ist, bestimmt nicht von Anfang an... oder ?
Das Lernen ist wie ein Meer ohne Ufer. Konfuzius

Alles wird Gut!

KEIN Support per Mail, ICQ oder PN !
www.heiseclan.de/fusion/sig.gif

www.heiseclan.de/geosig.gif
 
ingo21
Okay, danke für deine Hilfe, es lag an dem Forums-Pnael in der Mitte. Es war ein Update da waren diese schon vorhanden.

Aber da waren die Panels schon vorhanden und ich habe aber versehentlich die alten Panel Dateien überschrieben.
 
Springe ins Forum:
Heiseclan